Livepeer Studio Outage

Incident Report for Livepeer Studio

Postmortem

Postmortem

Livepeer Studio Outage

Date: 11/18/25

Time: 17:47 UTC

Summary:
The outage was triggered by an incident with our upstream hosting provider, which led to issues and disrupted access to Livepeer Studio services. After identifying the root cause, the team implemented corrective measures, closely monitored the resolution, and verified that all platform services were fully restored.

Impact:

  • Users were unable to stream, upload VODs, or play back existing streams in Livepeer Studio.
  • Developers could not create livestreams or upload assets via the Livepeer Studio API.
  • Daydream users relying on Studio playback experienced interruptions and could not view their streams.

Prevention:

To reduce the risk of similar incidents, the team is evaluating the use of a secondary hosting provider as a fallback plan.

Posted Nov 19, 2025 - 18:41 UTC

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 17:47 UTC

Update

Service has been restored by the third party, however there have been periods of intermittent downtime so we're monitoring very closely in case any issues occur again.
Posted Nov 18, 2025 - 14:48 UTC

Monitoring

Service has been restored by the third party, however there have been periods of intermittent downtime so we're monitoring very closely in case any issues occur again.
Posted Nov 18, 2025 - 14:46 UTC

Identified

Due to an issue with a third party provider we are seeing very high error rates for Studio API and the Dashboard.
Posted Nov 18, 2025 - 11:30 UTC
This incident affected: Livepeer Streaming API and Livepeer Studio dashboard.